Adding Family & Guest

Same issue here. Followed all the instruction sent to my email and still not getting the invitation to my family app.

1 Like

Same issue. Any light at the end of the tunnel?

1 Like

Same issue, looks like a bug to me.

Not sure whats going on but I set up 4 accounts without any trouble in the last 2 weeks. Doesn’t sound like a bug if it works for some people. Each account has a separate email and password for their account and I have 2 admins that can control all functions and 2 guests that can see the cams and doorbell and get alerts if they want.

1 Like

I thought I had the same problem, but it turned out the emails were in my junk folder. Have you checked that folder?

I am having the same issues with my parent’s set up.

To be clear, I have set this up for myself and my wife at our home, she has access under her own login. I am trying to repeat the steps for my dad and mum.

  1. Mum has received the email and clicked on the “activation” link (on a laptop).
  2. We then installed the Eufy Security app on her phone.
  3. Created her account on Eufy.
  4. Refreshed the home page, but no “Accept” button appears.

I have tried deleting the request from my dad’s phone and re-added the same email address, to which my mum did receive the email. Refreshed the app on mum’s phone, tried logging out of the app and relogging back in, still no “Accept” button on the Eufy Security. What she see’s is a brand new Eufy app with no home base etc.

We have followed the instructions, but the “Accept” button is not available. Just to repeat, I was able to set this up for myself and my wife at our home, but not sure why this is not working for my parents, the only difference is, we had set up this feature about a year ago. Not sure if something has changed recently.

Please help! Thanks in advance,

[edit] Admins, apologies for tagging this onto another thread, but it kind of seemed relevant to some of the other replies. If need be, let me know and I can start a new thread.


I think when your mom sees what looks like a brand new account without the Homebase, you need to check which devices you have set up for the her account. The device list can get out of sync if you add new devices, but don’t add them for the other accounts.

Go in to the Family and Guests menu with using the original account that you set up and invited the other accounts with. It should show a list of email addresses that have linked accounts. Make sure that your moms account has the devices you want her to see. If any are missing use the Manage Shared Devices choice to add any that are missing. Make sure to start with the homebase first.

Be aware that every time you add a new device, you will have to decide who you want to see it and add that device to their shared account manually.

Also, make a habit of using the master account for all device changes and share account changes or weird things can happen.


Hi Pysailr,

Thank you for your response. What you have suggested is something I have already checked,
i.e. “Go in to the Family and Guests menu with using the original account that you set up and invited the other accounts with. It should show a list of email addresses that have linked accounts. Make sure that your moms account has the devices you want her to see. If any are missing use the Manage Shared Devices choice to add any that are missing. Make sure to start with the homebase first.”

This was probably the second item I had double, triple checked. Again, this is not the first time I have tried to set this up. My personal unit at my home, I have successfully added myself and my wife to the users list etc and she can see the camera’s at our home. What I have tried to do is to duplicate this for my parents, but to no avail.

If there is any further help I can get on this, it would be extremely helpful.

Thanks in Advance!

Do your parents show in your list?

You said your mom received the email and clicked on the link on a laptop and then installed the app on her phone. I’m thinking there may be a disconnect there since she didn’t accept the link on the device she was going to be using. I’ll try creating another account tomorrow and see if I see anything by accepting the account on a different device.

Just to add to this - I’m having exactly the same problem. I set up our new doorbell yesterday. Sent invite to my wife via the app. She got an email telling her to download the app and set up an account, which she done, but no sign of any message to accept the invite. Still showing as ‘waiting’ in my app.

Anyone managed to find a fix for this?


Same issue here

Wish you could limit admin permissions on specific devices. Instead of giving permission to every device linked to a homebase, allow admin permission to home base bust guest privileges to specific cams/sensors etc…

I just set up another account today and didn’t have any problem. I sent the invite and then helped set up the app with the new account. Once the new account was created we logged into the account and got the confirmation. After than, we got an email with a verification code and a link so that we could confirm the setup was complete. Went fine and I didn’t see any issues at all.

Just a thought, but all my accounts were set up on Android. What OS are those who are having issues using?

Also, for those not getting the invite or verification codes, have you checked your spam folder?

All our devices are on Android. This is the strange thing - I tried sending an invite to another family member (using exactly the same process). When they downloaded the app and created their account, then when they logged in they got prompted in the app to accept the invitation and they were in without a problem.

I tried uninstalling the app from my wife’s phone, deleting the invite, and then starting the whole process again - and again it didn’t work. No prompt to accept the invite. Very very very strange.

I have the same problem. Unable to add Family and Guests using my new Eufy 1080P doorbell.

As above I use the master account and add email of my partners email. It says waiting on my app.

My partner gets the email invitation. I install the Eufy Security app on her android phone and she registers a new account with her email address which she gets an email to confirm registration.

She logs into the Eufy App on her phone without issues and the home screen has no notification at all so no devices to see! Done it 5 or 6 times now trying different guest and admin account invitations without joy!

I can log on to her phone with my account and see everything same as my phone but it wont work with her new account.

I’m at the point where I will just use my account on both phones which works but it should work as intended so a little disappointed with this bug as I only intended her to have guest permissions

Sounds like the process got hung up somewhere. Did she get the confirmation in the app and a second email with a 6 digit verification code? Thats how it worked for me. I am thinking that the without the second code, the link between the master account and her account doesn’t get created.

I have a account issue to check on this afternoon. I used the master account to upgrade one of my guests to admin and it upgraded both of them. Currently there is no way to downgrade the account so I’m going to delete the invite and try to re-create an account with guest privileges. I’ll check again and see if I can duplicate the problem you are having.

I am experiencing the same problem. My husband had to use my login info to get into the account. After he created his login info, there is no link to say “accept” the invite. Someone please fix this!!! Thanks

Same problem here, set this up on my wife’s iPhone 6s. Invited my email address set up my app on iPhone X, received the email with no links saying I should get a notification on my app.
Go to my app, no notification, logged in and out uninstalled the app reinstalled. No notification.
Only my wife is able to answer the door or check any of the cameras.
Please fix this guys, we’ve spent a lot of money on these devices including installation, for security, and only half our household can use them.

1 Like

he needs to create his own account using the email address that you sent the invite too. he cannot use your log in information because you will never see the pop up to accept the invite.

Everyone who is having trouble, you need to make sure that whoever is being sent the invite uses the email address that the invite was sent to when they create an account. That email address also has to be different from the master accounts email, otherwise you will never see the invite when you log in.

Already done that (a few times). Used different email account to master account, registered etc… All successful apart from getting no pop up notification.