Another update: Homebase stuck in "Updating"

I was gone for 2 days. Eufy has updated my camera system again.
Again without my permission.

While I was gone, the Homebase has gone into an update state.
In which it was stuck for 2 days, and the system was crippled.

This can be quite stressful, when you are on the road.
Another thing to worry about, while I am gone…

I could not access any of the cameras’ live views for 2 days.
The cameras did not send me any notifications of any events.
Some videos recorded though, which I found out by clicking on the recorded videos page in the iOS app. But I got no notifications.

When clicking on the Homebase within the iOS app, I could see its settings. I could even check the present firmware version. I could check for new updates.
But when I went back to see the list of my devices, they would all show “Updating”.

I tried to restart the Homebase remotely, using the iOS app.
That did not help.

After I got back, I tried to push the sync button on the cameras, to see it would do anything. It didn’t.
I also manually unplugged the Homebase, and restarted it. It did not work.

Then I thought of something.
If I can go into the Homebase settings, then I can try to make a small change on it (like changing system time), which might bring it back to life.
So I went into the Time settings and changed the 12/24 hour setting. Voila. After about 30 seconds, the Homebase and cameras were back online.

Two things:

  • Eufy: DO NOT UPDATE my system. Let me update on my schedule. If something would have happened during the past 2 days on my property, I would not have known about it. Let me update on my schedule. When I know, that I have time to deal with it.
  • If this happens to someone else, maybe they can try the same… change something small in their Homebase, and hopefully it will bring it back to life.

[Rant off]

1 Like

Exactly the same thing has happened to my battery doorbell after updating the firmware. Tried changing the time format, but still can’t get out of the ‘updating’ loop.

So frustrating!

Totally agree. I just saw the notification that ‘White Brick’ (HB2) just updated when I opened the app. This was between 4 and 5am, a time when I might have needed some Eufy security…

Tell us the update is available with some release notes and give us the option/choice to update our stuff when it’s convenient and safe for us. Looking at the release notes I didn’t need anything on this forced update anyway, I probably still would have updated, but let me choose if and when.

Mine has also been stuck in ‘Homebase is updating’ for the last two days
I tried the time change trick to no effect
I then ‘reststarted’ the Homebase Device from the App and this has done it.

Absolutely agree with these comments - you should NEVER force an update and you should leave it to the individual to choose IF they want to and WHEN

3 Likes

Yeah this crap is happening to me. Tried rebooting, changing settings, nothing works!

Suggestions from support chat got it working for me. I was able to get the home base to connect to a different wifi network then it stopped the update loop. Then I changed it back to the previous wifi network. The other thing they said to try but didn’t work was changing the alarm volume. Hope this helps someone!

Have the same issue “Homebase is updating” since yesterday.

Unfortunately rebooting (via application or by unplugging power source) and switching among ethernet and different wifi networks didn’t help.

Changing settings like alarm volume or time format give “Failed to request” error.

The homebase itself is online (discoverable in network and giving access to historical records). All cameras are connected but showing same “homebase is updating” logo.

Update 9/29/2020
I’ve experienced the same issues and received support advise as Hawkster.

The original issue “homebase stuck in updating” is gone as promised after early September restart.
However full workability of security system is not restored neither after numerous restart not after promised update of homebase firmware(2.1.2.2h) on 9/23.
The cameras are working in online mode, however no motion activated videos are captured.
Sending commands to cameras shows “Failed to request(6)” errors while looks like at least simple commands are executed(turn camera on/off) without displaying status.

Escalated the ticket back to Eufy support

Same as last post but my error message was the unable to connect to Homebase (-3). I’ve tried all the above solutions and nothing has worked for me. I’ve contacted Eufy support.

UPDATE: I haven’t received an answer today (Tuesday September 1st), but if I do I’ll update my post.

UPDATE 2: I received a email from Eufy support asking me to try the alarm volume slide setting solution which didn’t work for me and they asked me to upload a user log by going into the Side Menu (top left 3 lines) to:
About > tap Eufy logo 5 times (mine took 6) >
choose App log > upload user log.

The user log goes straight to engineering so they can evaluate your situation.
I’ve got to send a screenshot of the update loop like the OP showed.

UPDATE 3: I received the email from Eufy support about the user log saying that within 3 weeks they should have a update for the Homebase 2 and just apply it. This morning when I woke up the app was still in the update loop, but when I checked it just now everything was back to normal! So all is well… for now.
The Homebase 2 and cameras still have not updated and I’m not sure I want to try.

UPDATE 4: The camera update 1.6.7 and Homebase 2 2.1.2.2 h will not update when I try to on either one. The camera will only show live video and there are no notifications or recorded clips to view. I hope the next updates will solve this issue.

Cheers!