Eufy App with Dual SIM not working

I have a dual SIM on my iPhone 13, IOS 15.3 . The EUFY Security Apps version 4.0.0_867 and 3.5.2_851 cannot connect if the two SIMs are active with the Cellular.

I saw a similar issue reported and I was hoping to see Anker fixing the issue with the new version…

Seems that I would need to stop having 2 SIMS… Deactivating one does the job…

Any idea how to escalate the issue to Anker’s development team to test and qualify the app with multiple SIMs.


Give this a try! Ok, so I thought no I have a possible workaround for this frustrating issue. I have downloaded Spedify which is a VPN app which allows you to use both WiFi and mobile data simultaneously, I’m not sure why this works, but I think it tricks the app into thinking that it’s using WiFi. I’ve tried running the app even without connecting to a WiFi networks and it finally works! Just to note, this is a work around and Eufy REALLY need to resolve this issue and hope this highlights and proves that their app developers need to sort this out! This issue mainly affect dual SIM devices, so let me know if this has worked for you guys.