HomeKit away mode

I can’t get the IndoorCam to automatically switch to away mode. All settings in HomeKit are correct. As a test, I did not share the location of all devices (except one) in the iCloud settings. Nevertheless, the mode is not switched in HomeKit. Automations with the location of several devices, however, have long been working without problems. Is that a problem with eufy or HomeKit?