Not possible to add Indoor Cam 2K Pan & Tilt to HomeKit

I’ve had my two Indoor 2K Pan & Tilt for a couple of years now and all has been good. But recently they’ve been going up and down in Apples home app so I removed them from HomeKit, then removed them from the Eufy app, did a reset on both of them and then added them to the Eufy app again.

All good so far, they’re visible there and I can see the videos feed without any issues. Then I go to the HomeKit Portal to add the first one to HomeKit. I choose my home and continue, then I see the screen where it asks me if I want to add a camera to the home app. I press continue and it starts communicating with the camera. There it goes for about 3 minutes and then it times out and says it failed because it couldn’t connect with the camera. This happens for both cameras and I’ve tried adding them from the Eufy app both on my iPhone and on my iPad, same result.

How do I fix this?

firmware version and app version?

you need to submit a support log.

I use the latest firmware to my knowledge, version How do I submit a support log? And where?

In the app, there is about. u can submit log.
under help you submit feedback with the log number.