Update probleem

Hello, camera version 4.4.1 is showing in the app. I press update, it says it’s v.4.6.6, but it doesn’t update. What should I do?

1 Like

I’m having the same issue. Only bought them two days ago and I cannot update to 4.6.6. Sending them back tomorrow if there isn’t any word from them on how to fix it!!!

Any News on this. Same problem as you. It seems there are a few of us but interestingly only people who purchased this month.

Same here. Still no solution found.

I do have the same problem, our 2nd cam does not update to the latest firmware. I have the idea that there is a wrong badge or the firmware does not exist anymore???

That “check for update” button has never worked. Contact support and have them “push” it to you. This does work .

currently as far as I am aware from my experience and experience of others. There is no way of manually updating, even with a push from EUFY’s end from 4.4.1 to 4.4.6

EUFY are aware and they have stated there is no fix available at present. It’s as good as a door stop until they fix it